CAT Editor

The Editor is where your translation happens. This is the CAT tool that makes the translating process quick, smooth and efficient.

In order to open the Editor, click on a document on your list of files in a project.

Editor overview

Editor: the translation space

When you open the Editor, you will find your source text divided into numbered segments. An active source segment has three components:

  • The source text (_ST_)
  • The typing area for your target text (_TT_): you can type in your translation manually or insert a suggestion from the suggestion area. Alternatives for the next word to insert may appear in this area as ghost-words.
  • The suggestion area: TM matches above 75% are shown first. If a match does not exist, then the interactive MT output appears. This section is interactive, and it updates as you type.

The segment toolbar

There is a toolbar on the right-hand side of each segment. Its buttons change depending on the segment's activity and status.

In confirmed or unconfirmed segments that are active, you can refresh QA check, confirm the segment and access the Segment editing tools.

Segment toolbar collapsed

Using the Segment editing tools, you can:

  • Confirm a segment
  • Add comments to it
  • Merge it with the next or previous segment
  • Split a segment
  • Copy the ST into the TT area (you may want to use this option when you come across a complex and difficult fragment in the ST and you want to translate it expression by expression without looking up at the ST area)
  • Insert the entire suggestion into the TT area (check the Hotkeys section below for further details concerning insertion)

Segment toolbar expanded

When a segment has already been confirmed but is not active at the moment, the toolbar allows you to edit tags (if available) or unconfirm the segment.

Segment toolbar inactive

For inactive and unconfirmed segments, the toolbar will not be visible.

Comments

The Comments button is displayed on the right of each segment when it is active. If you are the only translator of a given document, you can use the option to add notes, to-do lists, etc. If there are more translators, you can use comments as a space for discussion. Read more on comments.

Tags

Lilt supports the import and export of tagged text. In the editor, you will see tagged spans in the source text. Most font styles (e.g., bold, italic, underline, color) will be rendered. Other arbitrary tags may not be shown although they will be preserved. When you are working with a tagged ST, translate the text as usual.

Tags

Tags show automatically after you confirm a segment and then click on the </> tags icon in the segment. Lilt will automatically place the tags for you. You can manipulate the tag placement if you find errors or want to make changes. Hover over a tag to see its type/content, drag and drop in order to edit the placement. Read more on tags.

QA

Quality Assurance (QA) points out mistakes and proposes corrections, which helps you make small, quick edits. A QA check runs automatically after you confirm a segment. If it detects any mistakes, they will be highlighted in different colors. You can go back to the segment and correct the mistakes.

QA

It is also possible to refresh QA by using the QA button on the segment toolbar. Moreover, you can run a QA check at any time by entering the Tools menu on the header bar and choosing Run QA to start it manually. Read more on QA.

Editor features

Translation Memory Matches

The Editor also includes a conventional translation memory (TM). Matches are indicated on the left-hand side, below the segment number, in the footer of each segment. There are tree match types and they are shown in the following order:

  • In-Context Match — a 101% or ICE match. The TM contains the exact source segment, and the texts in both the previous and next source segments also match the analogous entries in the TM.
  • Exact Match — a 100% match. The TM contains the exact source segment.
  • Fuzzy Match — a 75–99% match. The TM contains a similar source segment. The fuzzy match score is shown:

Fuzzy match

The header

The header bar gives you access to file options, settings, view options and tools.

Header

  • File - Allows you to download the translated text as TXT, XLIFF or in the original format of the file (i.e. the format in which the file was uploaded). If some parts of the text have not been translated yet, they will be preserved and shown in the file in the original language.
  • View – Allows you to change the way the segments are displayed. You may choose to see only the confirmed ones, the unconfirmed ones, or all. You may also switch to the Split view, in which the TT is on the left and ST (or the area in which to type it) on the right, as opposed to the horizontal view.
  • Tools – Here, you can directly manage roles (such as a translator and a reviewer). Moreover, you can turn on a QA check manually.
  • Settings – This menu allows you to choose the number of segments that you want to see per page in the Editor. You can also configure auto-propagation options, the TAB key function, the displaying invisible characters, as well as autocomplete and autoscroll options. You can also configure these settings by going to Account > Options.

Editor settings

On the right side of the header bar you can see your average translation speed, measured in the number of words per hour.

The footer bar allows you to:

  • See the name of the file you are working on and the language pair
  • Navigate segments and check how many have been confirmed
  • Check how many words have been translated out of the total number
  • See an estimate on how much time it will take to finish translating the document

Footer

The sidebar

You can use the tiles menu on the right to:

  • Access the Lexicon
  • Use the Find and Replace option, which allows you to search for words and expressions in both ST and TT
  • Use the Translate/Memory Search option
  • Access the list of all the documents you have in a given project, switch between them, and see the details for each (the number of words and segments, the percentage of confirmed and reviewed segments, and the total translation time so far)
  • See the Hotkeys cheatsheet

Sidebar menu

Hotkeys

The editor is designed to be operated entirely from the keyboard. The key interaction is autocomplete. Press Enter to insert the next highlighted word in the suggestion if you choose to accept it. Press Shift+Enter to insert the whole suggestion. Once you confirm your translation by pressing the check mark or Control+Enter, Lilt improves its suggestions for the rest of the segments.

This is the list of Hotkeys. You can access the cheatsheet anytime directly from the Editor, by choosing the question mark icon from the right-hand side tile menu. If the cheatsheet is not enough, there is a link to the full list at the top of it.

Windows Mac
Enter or Tab Return or Tab Insert the highlighted word
Shift + Enter Shift + Return Insert the complete suggestion
Control + Space Shift + Tab Select next word
Control + Shift + Space ⌘ + Shift + Space Insert non-breaking space
Control + Enter ⌘ + Return Confirm segment
Control + Down ⌘ + Down Go to next unconfirmed segment
Control + Up ⌘ + Up Go to previous unconfirmed segment
Control + Insert ⌘ + I Copy source to target
Control + Z ⌘ + Z Undo last change
Control + Alt + M Toggle comments
Alt + T Alt + T Open lexicon with selected text
F7 F7 Run QA check on current segment
Esc Esc Close TM diff view
Shift + F3 Shift + F3 Toggle case of highlighted text
Still need help? Get in touch!
Last updated on 16th November 2018